Post Reply 
Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
5D Mac Damaged Privileges
05-04-2017, 01:18 PM
Post: #1
5D Mac Damaged Privileges
I have 2 Drobo's connected to a 2013 Mac Pro (black can) running OS X 10.12.4. I've had the older Drobo for more than 3 years. It has 5 4-TB WD drives installed and it works fine.

Two weeks ago I had some problems with the other Drobo and as a precaution I ran First Aide from Apple's Disk Utility program against the older Drobo. It took about an hour and reported making some repairs. Since then some of the read/write privileges as shown by Get Info on the Drobo have been malfunctioning.

I have 3 user accounts on the Mac. All of them should be able to read and writ to the Drobo, but various folders are restricted to just one account. The Drobo is owned by my primary account and everyone has read & write privileges to it. After running First Aid, my other accounts can not access the Drobo without giving them explicit privileges. This shouldn't be needed.

Some second level folders now show different ownership depending on which account is currently active. This also should not be.

I can get at all my data, but I have to override a lot of privileges that worked fine before First Aid.

Has anyone here seen this kind of problem? Neither Apple nor Drobo tech support seems to have any insight into this issue.
Find all posts by this user
Quote this message in a reply
05-05-2017, 06:43 PM
Post: #2
RE: 5D Mac Damaged Privileges
hi rich, it may be that first aid somehow made the permissions go a a bit awry...
but is there a way for you to check in case there was any recent apple update, that possibly changed something in the way permissions are applied or inherited? (a bit like on windows a folder can inherit a parent folders settings)

is there another quick test you can try, such as setting up a new user on your mac, and creating a new folder at the root level, with permissions for each user, and then trying to copy something small into it (including some subfolders) and seeing if each user (including the 4th new user) can access it?

(btw i have XP home SP2, a Drobo v1 with 2x 1TB/2x 1.5TB WD greens, & a bkp Drobo v2 with the same + a DroboShare: unused)
& a DroboS v2 with 3xWD15EADS &2x1TB in DDR mode on win7, & a drobo5D (all usb)
  • btw i did a sustained (write) operation for about 6 hours, and got 13.2MB / sec ...objection? "sustained" :)
    (16.7MB/s on a v2 & 47-96MB/s drobo-s)
Find all posts by this user
Quote this message in a reply
05-11-2017, 06:28 PM
Post: #3
RE: 5D Mac Damaged Privileges
Hi Rich,

I would use 'Get Info' on the Drobo Drive and simply reset the access permissions for everything.

You can do this by adding the users explicitly into the 'Sharing & Permissions' Area, and selecting the Cog Icon and selection "Apply to Enclosed Items'.

Running Multi-Users I've had to do that a few times when the system seems to loose track of it.

You also at this level have the option of "Ignore ownership on this volume" which will tell the MacOS to simply allow any user to access any file or folder on this volume no matter who created it.
Find all posts by this user
Quote this message in a reply
Post Reply 

Forum Jump: