Post Reply 
 
Thread Rating:
  • 1 Votes - 2 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Video playback stutters after firmware update
07-09-2016, 12:32 PM
Post: #1
Video playback stutters after firmware update
I've built a Mac mini DVR that uses a 5D for storage. Last week I updated to firmware 3.5.0 [7.171.80644] and since then video playback stutters. This happens both for shows recorded via EyeTV as well as shows I've purchased via iTunes.

Is there a way to revert to the prior firmware?
Visit this user's website Find all posts by this user
Quote this message in a reply
07-09-2016, 01:35 PM
Post: #2
RE: Video playback stutters after firmware update
it may be that the new firmware has a slightly idea of the optimal block layout.

essentially sometimes after a firmware update your drobo maybe optimising itself (similar to a defrag). that could be causing the reduced performance

leave your drobo on for a few days and see if performance improves.

usually you cannot downgrade- the disk pack knows which version it needs to run it

My Avatar is my Panther Chameleon named 'Leon.

I have a owned a Drobo v1, v2, DroboPro, Drobo 5D, DroboFS, Drobo 5N and DroboPro FS

I currently have a Windows 2016 Server with 8 x 8TB Seagate Archive Drives, 14 x 8TB WD Red and 3 x 8TB WD Gold
Find all posts by this user
Quote this message in a reply
07-09-2016, 02:58 PM
Post: #3
RE: Video playback stutters after firmware update
Thanks - I guess it optimizes silently instead of telling you like it does when you replace drives? Last time I did that it told me "39 hours remaining" (4th image)

I've never installed an mSATA SSD, might that help? I know there used to be a list of supported mSATA drives, but can't find it now.
Visit this user's website Find all posts by this user
Quote this message in a reply
07-09-2016, 03:00 PM
Post: #4
RE: Video playback stutters after firmware update
yes it is silnt

it also scrubs silently and does lots o other maintainence tasks

the msata may

My Avatar is my Panther Chameleon named 'Leon.

I have a owned a Drobo v1, v2, DroboPro, Drobo 5D, DroboFS, Drobo 5N and DroboPro FS

I currently have a Windows 2016 Server with 8 x 8TB Seagate Archive Drives, 14 x 8TB WD Red and 3 x 8TB WD Gold
Find all posts by this user
Quote this message in a reply
07-14-2016, 11:49 AM (This post was last modified: 07-14-2016 11:50 AM by SpiceWare.)
Post: #5
RE: Video playback stutters after firmware update
It's been over a week since I did the firmware update and video playback is still stuttering. Considering my mini's on 24 hours a day, I would have expected any optimizing to be finished by now.

Think I'll head over to MicroCenter on my lunch break tomorrow pick up an MSATA for it. I know there used to be a list with supported drives on drobo.com, but I cannot find it anymore. These 3 look interesting, anybody have any experience with them in a Drobo?

Was also looking over the release notes and saw this: Fixes related to Apple Thunderbolt certification. Think I'll try connecting it via USB 3.0 first on the off chance the stutter is related to the Thunderbolt changes.
Visit this user's website Find all posts by this user
Quote this message in a reply
07-15-2016, 08:40 AM
Post: #6
RE: Video playback stutters after firmware update
USB 3 made it worse, pauses in video playback were longer in duration, so I reconnected it via Thunderbolt.
Visit this user's website Find all posts by this user
Quote this message in a reply
07-16-2016, 07:46 AM
Post: #7
RE: Video playback stutters after firmware update
Ended up getting a 250 GB Micron/Crucial MX200, which the Drobo is happy with (status screen shows "Hot Data Cache On" and "mSATA SSD Accelerator active").

The mSATA drive did not help with the playback stutter problem. Sad

Money was not wasted though - it significantly improved the performance of EyeTV (my DVR software) Smile It uses a directory full of files as its database and would frequently throw up the beach ball (Mac busy pointer) whenever it had to accessed that information.
Visit this user's website Find all posts by this user
Quote this message in a reply
08-19-2016, 03:06 PM
Post: #8
RE: Video playback stutters after firmware update
I too have a 5d with the 3.5.0 firmware and was suffering video stutters.

Support had me remove my 256GB msata card, and it *seems* to have stopped, but I'll bet it's an artifact of the 3.5.0 firmware.
Find all posts by this user
Quote this message in a reply
08-22-2016, 12:53 PM (This post was last modified: 08-22-2016 12:55 PM by Paul.)
Post: #9
RE: Video playback stutters after firmware update
hi spiceware,
usually the msata is good for lots of smaller files, rather than fewer huge files, so it's good that the msata helped you with your other software database.

one thing that may help is buffering. (while a lot of tools used to have this feature, and im not sure why it is not still used today), is a setting known as pre-buffering). for example, in the early days of windows media player, you could set in the software, a media stream to only start playing, once a certain % or megabytes were received.

on other devices, such as cd players, they had an anti-skip hardware feature, so that if you went jogging or something, you could set it to preload 5 seconds in advance (which only added 1-5 seconds of delay at the start), and then whenever you jolted the cd player, it would not matter because it already had enough data in the buffer.

even old programs like winamp used to have the pre-buffering features Smile

maybe your playback device has a buffer feature that can simply be enabled, or reconfigured for a few more seconds?
to me, that would fix a lot of issues, (unless heavy live real-time transcoding is taking place)

(btw i have XP home SP2, a Drobo v1 with 2x 1TB/2x 1.5TB WD greens, & a bkp Drobo v2 with the same + a DroboShare: unused)
& a DroboS v2 with 3xWD15EADS &2x1TB in DDR mode on win7, & a drobo5D (all usb)
  • btw i did a sustained (write) operation for about 6 hours, and got 13.2MB / sec ...objection? "sustained" :)
    (16.7MB/s on a v2 & 47-96MB/s drobo-s)
Find all posts by this user
Quote this message in a reply
08-23-2016, 11:43 AM
Post: #10
RE: Video playback stutters after firmware update
(08-22-2016 12:53 PM)Paul Wrote:  one thing that may help is buffering.

Thanks for the suggestion. I took a look but couldn't find any settings in EyeTV(DVR software) or iTunes (à la cart content)* for controlling playback buffer size. Not really surprised though, even the slow laptop drive in the mini is fast enough for stutter-free playback of local content.

I wonder if its related to the new 64 TB volume support, maybe reformatting the volume as 64 TB would help; however, I'd have to find a place to temporarily put 8 TB worth of data in order to do so.

I was planning to get the new 5Dt for my Mac Pro (Late 2013), which I could use to temporarily put the 8 TB of data on, but at this point I'm a bit wary of getting another Drobo.

* I put up an antenna and cut the cord at the start of 2013, the Mac mini drives my HDTV. I've saved over $1500 a year vs what I used to pay DirecTV, and get better picture quality to boot!
Visit this user's website Find all posts by this user
Quote this message in a reply
Post Reply 


Forum Jump: