Post Reply 
 
Thread Rating:
  • 0 Votes - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Drobo keeps warning of removed drive
03-03-2016, 01:05 PM
Post: #1
Drobo keeps warning of removed drive
My Gen 3 Drobo complained of a removed drive and so I noticed that the Dashboard had warnings on 2 of 4 drives. I replaced the drive that was "removed" and it rebuilt fine. I then replaced the 2nd drive that was indicating a warning and it now my Drobo continually reports "Drive redundancy in critical state with no extra drives due to a failed or removed drive" yet it doesn't show any drives offline. And then it goes into rebuild mode and then back to "drive redundancy..."

It's been repeating this process for the last 3 days. Anyway to get it to stop?
Find all posts by this user
Quote this message in a reply
03-03-2016, 02:46 PM
Post: #2
RE: Drobo keeps warning of removed drive
hi it might need time to fully rebuild.
usually a full rebuild can take about 1 day per 1TB of data that you have (plus a bit extra if still being used or accessed etc)

can you remember how much data you have on the drobo currently - if it is more than 3TB than it might be worth letting it continue for at least the 1day per 1TB of data (plus at least half a day more if you can?)

(btw i have XP home SP2, a Drobo v1 with 2x 1TB/2x 1.5TB WD greens, & a bkp Drobo v2 with the same + a DroboShare: unused)
& a DroboS v2 with 3xWD15EADS &2x1TB in DDR mode on win7, & a drobo5D (all usb)
  • btw i did a sustained (write) operation for about 6 hours, and got 13.2MB / sec ...objection? "sustained" :)
    (16.7MB/s on a v2 & 47-96MB/s drobo-s)
Find all posts by this user
Quote this message in a reply
03-03-2016, 04:36 PM
Post: #3
RE: Drobo keeps warning of removed drive
(03-03-2016 02:46 PM)Paul Wrote:  hi it might need time to fully rebuild.
usually a full rebuild can take about 1 day per 1TB of data that you have (plus a bit extra if still being used or accessed etc)

can you remember how much data you have on the drobo currently - if it is more than 3TB than it might be worth letting it continue for at least the 1day per 1TB of data (plus at least half a day more if you can?)

I have about 3TB of data. How do I force a full rebuild? It says it is rebuilding but then twice a day it complains that a drive went offline and then it comes back online and rebuilding continues.
Find all posts by this user
Quote this message in a reply
03-07-2016, 12:45 PM (This post was last modified: 03-07-2016 12:46 PM by Paul.)
Post: #4
RE: Drobo keeps warning of removed drive
thanks for the info,
if you can click on the drive in dashboard, does nay more information appear about it? (it could be that a particular drive is failing in some way and having errors that trigger the rebuild, which works, but then more sectors or errors are having problems, especially if it is the same drive that is being complained about?

(if you are also in cover, it might be good to raise a ticket with support about sending in some diagnostic logs as they will probably contain lots more info about what has been happening - though please do not generate any logs whie a rebuid is in process. you could also try creating a 1-time paid ticket in case out of support though as i believe they will be able to look at logs that way too)

(btw i have XP home SP2, a Drobo v1 with 2x 1TB/2x 1.5TB WD greens, & a bkp Drobo v2 with the same + a DroboShare: unused)
& a DroboS v2 with 3xWD15EADS &2x1TB in DDR mode on win7, & a drobo5D (all usb)
  • btw i did a sustained (write) operation for about 6 hours, and got 13.2MB / sec ...objection? "sustained" :)
    (16.7MB/s on a v2 & 47-96MB/s drobo-s)
Find all posts by this user
Quote this message in a reply
03-08-2016, 09:11 PM (This post was last modified: 03-08-2016 09:17 PM by tgabtg.)
Post: #5
RE: Drobo keeps warning of removed drive
I can click on the drives and see more info. One of the drives says "healed" It is a brand new drive that I just put in. I'm not covered by support because I refuse to pay Drobo any more $$. I've bought Gen 1, way too slow and unusable. Gen 2 too slow and barely usable and Gen 3 kinda slow but usable. I was hoping Gen 3 would be the answer to all my Drobo problems but now I've run into this issue and no more $$ is going to Drobo again.

I'm just leaving it in the rebuilding state and hopefully it will "recover" it's been a week...
Find all posts by this user
Quote this message in a reply
03-09-2016, 04:47 PM (This post was last modified: 03-09-2016 04:48 PM by Paul.)
Post: #6
RE: Drobo keeps warning of removed drive
thanks for the update, a week would seem quite a long time (for just 3TB data or there abouts) but there are some other factors that could slow it down, such as:

- something else using the drive (such as a computer search indexer or schedules virus scans for example)
- or the rebuild process successfully completing, but then another drive error triggers another full rebuild...

i think leaving it a bit longer is the next best thing to try, because if it did trigger a 2nd rebuild, then say 3.5days plus 3.5 days is at least a week, allowing a little bit, but the fact that you can see a Healed message, seems that that particular drive did have an error of some sort, and that the drobo was able to get past that error, but if it keeps encountering more errors, it may flag it with a warning or to completely mark it as bad.

if your actual data is still visible / accessible, and if your drobo does eventually complete the rebuild (or probably even if it has still not completed after what you feel is too long), then it would probably be a good idea to start copying and pasting your data (or at least the most important files) to another computer or drive, in the meantime, just in case that problematic drive ends up failing completely.

at some point, it would be worth replacing that drive with another one (if possible) but that would most probably require some cost unless you happen to have a spare blank or un-needed drive handy)

(btw i have XP home SP2, a Drobo v1 with 2x 1TB/2x 1.5TB WD greens, & a bkp Drobo v2 with the same + a DroboShare: unused)
& a DroboS v2 with 3xWD15EADS &2x1TB in DDR mode on win7, & a drobo5D (all usb)
  • btw i did a sustained (write) operation for about 6 hours, and got 13.2MB / sec ...objection? "sustained" :)
    (16.7MB/s on a v2 & 47-96MB/s drobo-s)
Find all posts by this user
Quote this message in a reply
Post Reply 


Forum Jump: