Post Reply 
 
Thread Rating:
  • 1 Votes - 3 Average
  • 1
  • 2
  • 3
  • 4
  • 5
5D not powering on
04-22-2015, 11:50 PM (This post was last modified: 04-23-2015 12:06 AM by thephotoq.)
Post: #1
5D not powering on
Helping my friend with her 5D, and unfortunately it's not powering on... When the power brick is connected, the LED starts blinking.
I brought my 5D brick over hoping that would do the trick, but not luck, same problem.
The brink blinks and no lights on the DROBO.

Hope I can find some help in these forums that has been lacking from DROBO.
She's been a customer for years is on her fourth DROBO. She upgraded to the 5D because even though her last DR04DD14 (*edit, that was her 1st, her last was a DRDR3A21) was still under the extended warranty, DROBO said they no longer offered support for it.
Now her new DROBO is 2 months out of support (she thought she purchased the extension but was mistaken). Last calls to DROBO ended with "call back again, maybe the next person will help you" and an emailed reply of "no we won't support or sell you an extension of support, no exceptions."

Really disappointing. Not my first issue with DROBO, but certainly the most troubling.
I work in tech and commercial photography and I've setup dozens of DROBOs, recommended them constantly. Now I'm seriously starting to regret it.
Find all posts by this user
Quote this message in a reply
Post Reply 


Messages In This Thread
5D not powering on - thephotoq - 04-22-2015 11:50 PM
RE: 5D not powering on - isurrender - 05-08-2015, 03:17 PM
RE: 5D not powering on - Paul - 05-14-2015, 12:26 PM
RE: 5D not powering on - darkchil1d - 05-21-2015, 04:04 AM
RE: 5D not powering on - Paul - 05-21-2015, 01:12 PM
RE: 5D not powering on - DroboMod - 05-22-2015, 09:18 AM
RE: 5D not powering on - lichtreim - 05-24-2015, 01:24 PM
RE: 5D not powering on - dbouchon - 08-13-2015, 11:21 AM
RE: 5D not powering on - DroboMod - 08-28-2015, 02:11 PM
RE: 5D not powering on - kireix - 08-28-2015, 01:15 PM
RE: 5D not powering on - DroboMod - 08-28-2015, 02:12 PM
RE: 5D not powering on - scottwinters - 09-08-2015, 01:52 PM
RE: 5D not powering on - DroboMod - 09-10-2015, 10:02 AM
RE: 5D not powering on - Paul - 09-08-2015, 03:33 PM
RE: 5D not powering on - scottwinters - 09-08-2015, 04:15 PM
RE: 5D not powering on - Paul - 09-09-2015, 03:53 PM
RE: 5D not powering on - nickle - 09-17-2015, 07:23 PM
RE: 5D not powering on - Paul - 09-18-2015, 09:26 AM
RE: 5D not powering on - helimat - 09-26-2015, 12:11 PM
RE: 5D not powering on - Paul - 09-28-2015, 10:33 AM
RE: 5D not powering on - helimat - 09-30-2015, 09:04 PM
RE: 5D not powering on - Paul - 10-01-2015, 09:28 AM
RE: 5D not powering on - helimat - 10-05-2015, 09:34 PM
RE: 5D not powering on - Paul - 10-06-2015, 10:13 AM
RE: 5D not powering on - helimat - 10-06-2015, 08:54 PM
RE: 5D not powering on - Paul - 10-07-2015, 12:18 PM
RE: 5D not powering on - helimat - 10-12-2015, 10:47 AM
RE: 5D not powering on - Paul - 10-12-2015, 02:27 PM
RE: 5D not powering on - ikomrad - 10-29-2015, 07:19 PM
RE: 5D not powering on - Paul - 10-30-2015, 12:24 PM
RE: 5D not powering on - drchevalier - 11-08-2015, 05:43 PM
RE: 5D not powering on - MarkBanjas - 11-14-2015, 09:34 AM
RE: 5D not powering on - hobbym - 11-19-2015, 01:37 PM
RE: 5D not powering on - Paul - 11-20-2015, 11:26 AM
RE: 5D not powering on - taylorehat - 11-25-2015, 11:46 AM
RE: 5D not powering on - Paul - 11-26-2015, 11:44 AM
RE: 5D not powering on - taylorehat - 11-28-2015, 12:48 PM
RE: 5D not powering on - Paul - 11-30-2015, 01:22 PM
RE: 5D not powering on - Smurffy - 12-15-2015, 08:42 AM
RE: 5D not powering on - stianrasmussen - 02-03-2016, 03:45 PM
RE: 5D not powering on - Paul - 02-03-2016, 03:59 PM
RE: 5D not powering on - moodle - 07-27-2016, 12:02 PM
RE: 5D not powering on - Paul - 07-28-2016, 11:28 AM
RE: 5D not powering on - wfiveash - 09-18-2016, 05:11 PM
RE: 5D not powering on - Paul - 09-19-2016, 04:00 PM
RE: 5D not powering on - Paul - 03-31-2017, 04:51 PM
RE: 5D not powering on - Paul - 04-03-2017, 01:44 PM
RE: 5D not powering on - DougSO - 04-30-2017, 11:43 PM
RE: 5D not powering on - Paul - 05-02-2017, 06:55 PM
RE: 5D not powering on - DougSO - 05-03-2017, 03:59 PM
RE: 5D not powering on - Paul - 05-05-2017, 06:18 PM

Forum Jump: